Resolved
Failed exports have been automatically retried and completed successfully. All systems are operating normally.
Monitoring
We have deployed a fix and are now seeing speed-adjusted exports completing successfully. Please retry any failed exports to receive your downloads, otherwise they will be automatically retried over the next hour.
Identified
We're experiencing an elevated number of failed export requests when "Faster/slower" is selected. We have identified the root cause and are working on a mitigation. Exports at 1x speed are unaffected.