Resolved
This incident has been resolved. All systems are operating normally. Thank you for your patience.
Monitoring
A fix has been deployed and we're seeing recovery. We're monitoring to ensure stability. If you experienced issues during this period, please try again or reach out to our team at support@tella.com.
Investigating
We are investigating an issue where videos are not loading on the My Videos page for some users. Our engineering team is investigating and will provide an update as soon as we have one to share.