Resolved
The backlog has been cleared since 8:24 AM PT and everything is back and operational. We appreciate your patience.
Monitoring
Our team has implemented a fix and are monitoring. We are working through a backlog, but video playback and exports should be available. We appreciate your patience and will update when the backlog is cleared.
Investigating
Some users are experiencing degraded performance with video playback and exports. Our engineering team is investigating and will provide an update ASAP.