No components marked as affected
Resolved
Our upstream provider has resolved the issue. Images should appear on tella.com correctly now. Thanks for your patience.
Identified
We're aware of issues affecting images not being loaded on tella.com, our marketing site and are working with our upstream provider to investigate. Our website itself is resolvable and functional. We'll share updates as we have them.